require PHP < 7.4.0 !